Задрало NoSuchElementException в Selenium WebDriver





Сегодня 22.09.2011, в этот прекрасный выходной день, я решил поработать и позапускать своей автотесты на java в версии фаерофокса 15.0.1 с последней версией selenium-server-standalone-2.25.0.jar

И что же я замечаю, а я замечаю что чуть ли не половина моих тестов падает, на элементах, локаторы которых находятся правильно и всю жизнь находились правильно, но тут не с того ни с сего все падают с ошибкой:

org.openqa.selenium.NoSuchElementException: Unable to locate element: {«method»:»css selector»,»selector»:»div#NewFolders»}
Command duration or timeout: 30.12 seconds
For documentation on this error, please visit: http://seleniumhq.org/exceptions/no_such_element.html
Build info: version: ‘2.25.0’, revision: ‘17482’, time: ‘2012-07-18 21:08:56’
System info: os.name: ‘Windows 7’, os.arch: ‘amd64’, os.version: ‘6.1’, java.version: ‘1.6.0_26’
Driver info: driver.version: RemoteWebDriver
Session ID: 4ee39de5-9dcd-4e4f-866f-51f31f0d99d6

И т д

Запустил все «проблемные» тесты в хроме и все они идеально прошли. Меня уже просто задрало, что с выходом новой версии фаерфокса селениум перестает нормально работать, почему с хромом нет таких проблем? Вывод: запускайте автотесты в хроме и не партесь.



Поделиться в соц. сетях

Опубликовать в Одноклассники
Опубликовать в Google Plus
Опубликовать в Мой Мир
Опубликовать в Google Buzz
Опубликовать в LiveJournal
Опубликовать в Яндекс

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *